设为首页收藏本站新闻投稿

MOD中国同盟社

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 868|回复: 1

E语言制作简易的应用程序管理软件 [复制链接]

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2011-8-27 22:42:34 |显示全部楼层
本帖最后由 玲心韩雪 于 2011-8-27 22:46 编辑

简易的快捷方式,和,EXE管理器
简单的说程序的BUG还是比较大的,给大家拿回去学习了1 高手指点一下迷津!

.版本 2
.DLL命令 skin, , "config\skin\sheskin.dll", "skin"

.版本 2
.支持库 iext
.支持库 xplib
.支持库 shell
.程序集 主窗口_命令集
.程序集变量 文件, 文本型
.程序集变量 文件号, 整数型
.程序集变量 文件名, 文本型, , "0"
.程序集变量 X, 文本型
.程序集变量 S, 文本型
.程序集变量 A, 文本型
.程序集变量 B, 文本型
.程序集变量 F, 文本型
.子程序 __启动窗口_创建完毕
_启动窗口.图标 = 读入文件 (取运行目录 () + “\config\skin\cstrike.ico”)
通用对话框1.过滤器 = “快捷方式 (*.lnk) or 应用程序 (*.exe)|*lnk;*.exe”
状态条1.置文本 (3, “状态:运行正常”)
F = 读配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttite”, )
B = 读配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttita”, )
XP风格 (2)
优化自身内存 ()
优化所有进程内存 ()
skin ()
S = 取运行目录 () + 读配置项 (取运行目录 () + “\config\config.cfg”, “config”, “text”, )
文件 = 寻找文件 (取运行目录 () + “\bin\*”, )
.判断循环首 (文件 ≠ “”)
    .如果真 (取文本右边 (文件, 4) = “.Lnk”)
        树型框1.加入项目 (0, 文件, 6, , , , )
        状态条1.置文本 (0, “当前被加入的文件名:” + 文件)
        树型框1.显示连线 = 真
        加入成员 (文件名, 文件)
        文件号 = 文件号 + 1
        状态条1.置文本 (1, “被加入的文件总个数:” + 到文本 (文件号))
    .如果真结束
    文件 = 寻找文件 (, )
.判断循环尾 ()

.子程序 _时钟1_周期事件
文件 = 寻找文件 (取运行目录 () + “\bin\*”, )
.判断循环首 (文件 ≠ “”)
    .如果真 (取文本右边 (文件, 4) = “.lnk”)
        树型框1.加入项目 (0, 文件, 6, , , , )
        状态条1.置文本 (0, “当前被加入的文件名:” + 文件)
        树型框1.显示连线 = 真
        加入成员 (文件名, 文件)
        文件号 = 文件号 + 1
        状态条1.置文本 (1, “被加入的文件总个数:” + 到文本 (文件号))
    .如果真结束
    文件 = 寻找文件 (, )
.判断循环尾 ()
时钟1.时钟周期 = 0
.子程序 _树型框1_双击项目
X = 到文本 (树型框1.取项目文本 (树型框1.现行选中项))
编辑框1.内容 = X
执行 (, S + 编辑框1.内容, , , )
执行 (, 读配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttite”, ) + 编辑框1.内容, , , )
执行 (, 读配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttita”, ) + 编辑框1.内容, , , )
编辑框1.内容 = “”
X = “”
.子程序 _添加_被选择
.如果真 (通用对话框1.打开 () = 真)
    .判断开始 (通用对话框1.文件名 ≠ “”)
        A = 通用对话框1.文件名
        .如果真 (A ≠ “”)
            树型框1.加入项目 (6, A, 6, , , , )
            状态条1.置文本 (0, “当前被加入的文件名:” + 文件)
            加入成员 (文件名, A)
            文件号 = 文件号 + 1
            状态条1.置文本 (1, “被加入的文件总个数:” + 到文本 (文件号))
        .如果真结束
    .默认
        返回 ()
    .判断结束
    返回 ()
.如果真结束

.子程序 _保存_被选择
.如果真 (取数组成员数 (文件名) = 0)
    返回 ()  ' //校验有没有列表文件
.如果真结束
通用对话框2.类型 = 1
.如果真 (通用对话框2.打开 ())
    .如果 (保存列表 (通用对话框2.文件名))
        信息框 (“保存列表成功!”, 64, )
    .否则
        信息框 (“保存列表失败!”, 48, )
    .如果结束
.如果真结束

.子程序 保存列表, 逻辑型
.参数 文件名称, 文本型
.局部变量 临时文件, 文本型
.局部变量 变量
临时文件 = “edb”
.计次循环首 (取数组成员数 (文件名), 变量)
    临时文件 = 临时文件 + #换行符 + 文件名 [变量]
.计次循环尾 ()
临时文件 = 临时文件 + #换行符 + “end”
.如果 (写到文件 (文件名称 + “.edb”, 到字节集 (临时文件)))
    返回 (真)
.否则
    返回 (假)
.如果结束

.子程序 _树型框1_鼠标右键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型
弹出托盘菜单 (程序)

.子程序 _时钟2_周期事件
优化自身内存 ()
优化所有进程内存 ()

.子程序 _添加应用程序文件夹_被选择
B = 浏览文件夹 (“浏览并添加应用程序文件夹”, 真)
写配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttita”, B + “\”)
.如果 (B ≠ “”)
    文件 = 寻找文件 (B + “\*”, )
    .判断循环首 (文件 ≠ “”)
        .如果真 (取文本右边 (文件, 4) = “.exe”)
            树型框1.加入项目 (6, 文件, 6, , , , )
            状态条1.置文本 (0, “当前被加入的文件名:” + 文件)
            加入成员 (文件名, B + “\” + 文件)
            文件号 = 文件号 + 1
            状态条1.置文本 (1, “被加入的文件总个数:” + 到文本 (文件号))
            树型框1.显示连线 = 真
        .如果真结束
        文件 = 寻找文件 (, )
    .判断循环尾 ()
.否则
    返回 ()
.如果结束


.子程序 _载入_被选择
通用对话框2.类型 = 0
.如果真 (通用对话框2.打开 ())
    载入列表 (通用对话框2.文件名)
.如果真结束


.子程序 载入列表
.参数 文件名称, 文本型
.局部变量 临时文件, 文本型
.局部变量 变量, 整数型
文件号 = 打开文件 (文件名称, , )
移到文件首 (文件号)
临时文件 = 读入一行 (文件号)
.如果真 (临时文件 ≠ “edb”)
    信息框 (“不是有效的列表文件”, 16, “文件载入错误”)
    关闭文件 (文件号)
    返回 ()
.如果真结束
.判断循环首 (是否在文件尾 (文件号, ) = 假)
    临时文件 = 读入一行 (文件号)
    .如果 (临时文件 ≠ “end”)
        加入成员 (文件名, 临时文件)
        树型框1.加入项目 (6, 临时文件, 6, , , , )
    .否则
        跳出循环 ()
    .如果结束
.判断循环尾 ()
.子程序 _添加文件夹及其子文件夹的所有应用程序_被选择
F = 浏览文件夹 (“浏览并添加文件夹及其子文件夹的所有应用程序”, 假)
写配置项 (取运行目录 () + “\config\config.cfg”, “config”, “sttite”, F + “\”)
.如果 (F ≠ “”)
    文件 = 寻找文件 (F + “\*”, 1 + 2 + 4 + 16 + 32)
    .判断循环首 (文件 ≠ “”)
        .如果真 (取文本右边 (文件, 4) = “.exe”)
            树型框1.加入项目 (7, 文件, 6, , , , )
            状态条1.置文本 (0, “当前被加入的文件名:” + 文件)
            加入成员 (文件名, F + “\” + 文件)
            状态条1.置文本 (1, “被加入的文件总个数:” + 到文本 (文件号))
            树型框1.显示连线 = 真
        .如果真结束
        文件 = 寻找文件 (, )
    .判断循环尾 ()
.否则
    返回 ()
.如果结束

.子程序 _时钟4_周期事件
.如果真 (文件是否存在 (取运行目录 () + “\config\Project.edb”) = 假)
    .如果真 (信息框 (“Project.edb系统文件丢失,是否还原!”, 1 + #信息图标, “运行错误:”) = 0)
        写到文件 (取运行目录 () + “\config\Project.edb”, #啊)
    .如果真结束
    返回 ()
.如果真结束

.如果真 (取数组成员数 (文件名) = 0)
    返回 ()  ' //校验有没有列表文件
.如果真结束
.如果 (保存列表 (取运行目录 () + “\config\Project”) = 真)
.否则
.如果结束

.子程序 _时钟5_周期事件
载入列表 (取运行目录 () + “\config\Project.edb”)
时钟5.时钟周期 = 0


START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 2

帖子
18
精华
0
声望
129 点
金币
15 Mold
被赞许
0 次
注册时间
2011-6-11
发表于 2011-11-19 09:31:40 |显示全部楼层
:'(:'(:'(过期了

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

回顶部