设为首页收藏本站新闻投稿

MOD中国同盟社

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 1768|回复: 4

[推荐] 易语言制作TP安全启动超逼真!   [复制链接]

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2011-8-27 23:54:24 |显示全部楼层
本帖最后由 玲心韩雪 于 2011-8-27 23:57 编辑

下载地址:
TP_安全_启动_下载地址
.版本 2
.支持库 eAPI
.程序集 窗口程序集_主窗口
.程序集变量 水晶进度条, 水晶进度条类
.程序集变量 主题风格, 整数型
.程序集变量 X
.子程序 __启动窗口_创建完毕
.局部变量 y, 整数型
.局部变量 n, 整数型
.局部变量 w, 文本型
y = 取屏幕宽度 () - 256
n = 取屏幕高度 () - 128
w = “”
_启动窗口.移动 (y, n, , )
置外形图片 (_启动窗口.底图, #黑色)
水晶进度条.初始化 (画板1)
水晶进度条.最小位置 (0)
水晶进度条.最大位置 (100)
水晶进度条.位置 (0)
水晶进度条.圆角度 (21)
主题风格 = 8
水晶进度条.主题风格 (主题风格)
水晶进度条.文本效果 (4)
水晶进度条.滚动方向 (1)
水晶进度条.文本显示风格 (3)
水晶进度条.文本效果颜色 (#银白)
水晶进度条.文本颜色 (#品红)
水晶进度条.文本 (w)
.子程序 _画板1_绘画
.参数 重画区左边, 整数型
.参数 重画区上边, 整数型
.参数 重画区右边, 整数型
.参数 重画区下边, 整数型
水晶进度条.画图 ()
.子程序 _时钟1_周期事件
.局部变量 B, 文本型
B = “安全系统_启动完成”
水晶进度条.位置 (水晶进度条.位置 () + 1)
.判断开始 (水晶进度条.位置 () ≥ 99)
    水晶进度条.文本 (B)
    时钟1.时钟周期 = 0
.默认
.判断结束

.子程序 _时钟2_周期事件
.如果 (时钟1.时钟周期 = 0)
    X = 255
    时钟3.时钟周期 = 30
    时钟2.时钟周期 = 0
.否则
.如果结束


.子程序 _时钟3_周期事件
X = X - 8
设置窗口透明度 (取窗口句柄 (), X)
.如果真 (X ≤ 1)
    _启动窗口.可视 = 假
    结束 ()
.如果真结束



START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 2

帖子
31
精华
0
声望
97 点
金币
7 Mold
被赞许
0 次
注册时间
2011-7-30
发表于 2011-8-28 12:26:44 |显示全部楼层
LZ自己做的么?

使用道具 举报

头像被屏蔽

禁止发言

帖子
74
精华
0
声望
48 点
金币
-28 Mold
被赞许
-4 次
注册时间
2011-8-26
发表于 2011-8-28 13:13:06 |显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

使用道具 举报

Super Moderator

职业杀手

Rank: 10Rank: 10Rank: 10

帖子
1592
精华
0
声望
6291 点
金币
1753 Mold
被赞许
51 次
注册时间
2009-9-29

热心会员奖 黑暗使者 可爱小猫

发表于 2011-8-28 13:41:55 |显示全部楼层
来个图

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2011-8-28 13:57:57 |显示全部楼层
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

回顶部