设为首页收藏本站新闻投稿

MOD中国同盟社

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 1080|回复: 10

[教程] 基于VE(易语言)无法控制音量的原因现在我提供代码解决 [复制链接]

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-25 23:51:38 |显示全部楼层
本帖最后由 玲心韩雪 于 2012-4-26 00:00 编辑

基于VE(易语言)无法控制音量的原因现在我提供一下代码给大家看看
.版本 2
.子程序 __启动窗口_创建完毕
主系统音量.打开 (4)
波形系统音量.打开 (4104)
麦克系统音量.打开 (4099)
CD系统音量.打开 (4101)
电话线系统音量.打开 (4102)
线路系统音量.打开 (4098)
软件系统音量.打开 (4100)

算法
.版本 2
.支持库 eMMedia
.子程序 _滑块条1_位置被改变
.局部变量 音量, 整数型, , "1,2"
主系统音量.取音量 (音量 , 音量 [2])
音量 [1] [1] = 主系统音量.取最大音量 () ÷ 滑块条1.最大位置 × (滑块条1.最大位置 - 滑块条1.位置)
主系统音量.置音量 (音量 [1] [1], 音量 [1] [2])

运算法则同上
还有一种运算法则, 暂不公布

附件: 你需要登录才可以下载或查看附件。没有帐号?注册
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-25 23:57:56 |显示全部楼层
系统静音法则 1 OCX控件
.版本 2
.支持库 eMMedia
.子程序 _全部静音选择框_被单击
主系统音量.置静音 (全部静音选择框.选中)
系统静音/解除法则 2 DLL
.版本 2
.子程序 _静音解除_被选择
发送消息 (取窗口句柄 (), 793, 2100912, 524288)


START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
165
精华
0
声望
2430 点
金币
471 Mold
被赞许
5 次
注册时间
2011-6-2
发表于 2012-4-26 11:55:11 |显示全部楼层
提个问题:易语言为什么叫VE
还有,系统音量的我会调,我要的是程序输出音量大小..

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-26 11:56:53 |显示全部楼层
本帖最后由 玲心韩雪 于 2012-4-26 11:58 编辑
小炀火线 发表于 2012-4-26 11:55
提个问题:易语言为什么叫VE
还有,系统音量的我会调,我要的是程序输出音量大小.. ...
貌似 声波可以控制,我在WIN7下,是控制 改程序的音量,XP未试验!

你问的 问题是神马,我暂不做回答
如果你要问,那我反问 VC为什么要叫VC
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-26 12:00:12 |显示全部楼层
本帖最后由 玲心韩雪 于 2012-4-26 12:01 编辑

实在不行, 易语言 调用 Windows Media Player 窗口,也行,只不过 是需要 一个 类型库变量
暂不作解释!
这100%控制 声波,,,控制声波,E语言 还没的,VC倒是没问题,
谁叫E语言是 VC开发的 副本吗!
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 3Rank: 3

帖子
171
精华
0
声望
352 点
金币
145 Mold
被赞许
-1 次
注册时间
2011-8-14
发表于 2012-4-26 16:43:37 |显示全部楼层
易语言早忘了,2010学的

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
165
精华
0
声望
2430 点
金币
471 Mold
被赞许
5 次
注册时间
2011-6-2
发表于 2012-4-26 17:24:36 |显示全部楼层
玲心韩雪 发表于 2012-4-26 11:56
貌似 声波可以控制,我在WIN7下,是控制 改程序的音量,XP未试验!

你问的 问题是神马,我暂不做回答

问题是VC那是微软的,E是中国的,排不到同一个公司啊

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-26 17:31:43 |显示全部楼层
小炀火线 发表于 2012-4-26 17:24
问题是VC那是微软的,E是中国的,排不到同一个公司啊

不一定说 VC是 Microsoft的啊
VC有几种
出自不同公司
但是编译代码都是一样的!
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
165
精华
0
声望
2430 点
金币
471 Mold
被赞许
5 次
注册时间
2011-6-2
发表于 2012-4-26 19:46:27 |显示全部楼层
玲心韩雪 发表于 2012-4-26 17:31
不一定说 VC是 Microsoft的啊
VC有几种
出自不同公司

VC就是Visual C,而Visual是“微软公司开发的编程工具

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-4-26 21:25:14 |显示全部楼层
小炀火线 发表于 2012-4-26 19:46
VC就是Visual C,而Visual是“微软公司开发的编程工具”

看来你,对 C语言 还不够了解,这么基本的你都不知道!
Turbo C
VC
V#
C++
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

回顶部