设为首页收藏本站新闻投稿

MOD中国同盟社

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 710|回复: 0

[原创] 易语言 命令行操作系列,如果你不会写,你就使用超级模块 [复制链接]

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 02:43:13 |显示全部楼层

PathIsDirectoryA       DLL 命名   这个就是最高效地 识别文件目录是否存在



.版本 2
.支持库 wmp9
.子程序 处理命令行
.局部变量 命令行数组, 文本型, , "0"
.局部变量 处理命令行变量, 文本型
.局部变量 变量, 文本型, , "0"
.局部变量 索引
.局部变量 A
.局部变量 B
取命令行 (命令行数组)
.如果真 (取数组成员数 (命令行数组) = 0)
    返回 ()
.如果真结束
.如果真 (文件是否存在 (命令行数组 ) = 假)
    返回 ()
.如果真结束
处理命令行变量 = 到文本 (命令行数组 )
.如果 (文件是否存在 (处理命令行变量) = 假)
    返回 ()
.否则
    ' 识别目录 (处理命令行变量)
    ' 加入成员 (变量, 处理命令行变量)
    .' 如果真 (取数组成员数 (变量) ≠ 0)
        ' B = 取数组成员数 (变量)
        .' 计次循环首 (取数组成员数 (变量), 索引)
            ' A = A + 1
            ' B = B - 1
            .' 如果真 (A ≤ 取数组成员数 (变量) 且 B ≤ 取数组成员数 (变量))
                .' 如果 (到文本 (变量 [A]) ≠ 到文本 (变量 [B]))
                    播放器.地址 = 处理命令行变量
                    控制.播放 ()
                    窗口集变量文件 = 处理命令行变量
                    _分割文本识别目录 (窗口集变量文件)
                    ' 跳出循环 ()
                .否则
                    ' 返回 ()
                .如果结束
            .如果真结束
        .' 计次循环尾 ()
    .如果真结束
.如果结束

.子程序 _分割文本识别目录
.参数 文件名, 文本型
.局部变量 文本总长
.局部变量 索引
.局部变量 被减变量
.局部变量 变量返回值, 文本型
.局部变量 运算符变量, 文本型
.局部变量 未知文件名变量, 文本型
.局部变量 变量, 文本型, , "0"
文本总长 = 取文本长度 (文件名)
被减变量 = 文本总长
.计次循环首 (文本总长, 索引)
    被减变量 = 被减变量 - 1
    .如果真 (被减变量 ≥ 0)
        运算符变量 = 取文本左边 (文件名, 被减变量)
        变量返回值 = 运算符变量
        .如果真 (目录是否存在 (运算符变量))
            未知文件名变量 = 取文件名称_2 (运算符变量, 文件名)
            加入成员 (变量, 运算符变量)
            .如果真 (文件是否存在 (变量返回值 + “\” + 未知文件名变量) = 真)
                改变目录 (变量返回值)
                ' 音乐列表框.插入表项 (0, 未知文件名变量, , , , )
                ' 音乐列表框.置标题 (0, 1, 变量返回值)
                ' 音乐列表框.置标题 (0, 2, 读媒体时间 (变量返回值 + “\” + 未知文件名变量))
                ' 音乐列表框.置标题 (0, 3, 取文件后缀名 (变量返回值 + “\” + 未知文件名变量, 4))
                ' 音乐列表框.置标题 (0, 4, “1次”)
                ' 音乐列表框.置标题 (0, 3, 取文件后缀名 (变量返回值 + “\” + 未知文件名变量, 4))
                写数据 (真, 未知文件名变量, 变量返回值 + “\”, 读媒体时间 (变量返回值 + “\” + 未知文件名变量), 1, 取记录号 () + 1, 取文件后缀名 (变量返回值 + “\” + 未知文件名变量, 4))  ' -- 执行不了
                ' 读数据 (真)
                跳出循环 ()
            .如果真结束
        .如果真结束
    .如果真结束
.计次循环尾 ()

附件: 你需要登录才可以下载或查看附件。没有帐号?注册
已有 1 人评分被赞许 收起 理由
﹏夜幕ノ战士 + 1 。。。。。。。。。。。

总评分: 被赞许 + 1   查看全部评分

START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

回顶部