设为首页收藏本站新闻投稿

MOD中国同盟社

 找回密码
 注册

QQ登录

只需一步,快速开始

搜索
查看: 456|回复: 6

[推荐] omnipotence paly 支持 命令行,支持拖放文件,,,支持对文件属性取 [复制链接]

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 16:24:00 |显示全部楼层

文件属性的获取,,,就写了几样,,,没有写 读MP3 V1 V2 信息,,,估计是不必了




拖放文件到 播放器OCX 控件上 播放,列表刷新,,呵呵 截不了怎在拖放的文件


文件关联,,,接收命令行,,,但是 有缺点,比如上面的拖放文件
就是无法取出 文件目录,文件名称
已被我解决

文件格式支持数量、


重新编写,,,cmd.cmd,为EXE文件,,,不是易语言编写,,,不是BAT转EXE,使用。。。编译软件



附件: 你需要登录才可以下载或查看附件。没有帐号?注册
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 16:26:32 |显示全部楼层

动画窗口
,,,,
我记得我发过该DLL命令的哈
条用值22
从中心向外扩展
附件: 你需要登录才可以下载或查看附件。没有帐号?注册
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 20:05:27 |显示全部楼层
.版本 2
.支持库 wmp9
.支持库 iext

.子程序 _URL输入编辑框_字符输入, 整数型
.参数 字符代码, 整数型
.局部变量 临时媒体, 播放器媒体
.局部变量 tempA, 文本型

.如果真 (字符代码 = #回车键)
    tempA = URL输入编辑框.内容
    .判断开始 (取文本左边 (tempA, 4) = “http”)
        _启动窗口.播放器.地址 = URL输入编辑框.内容
        控制.播放 ()
        临时媒体 = _启动窗口.播放器.取当前媒体 ()
        _启动窗口.音乐列表框.全部删除 ()
        _启动窗口.目录识别框.清空 ()
        .如果 (临时媒体.取项目信息 (“FileType”) = “swf”)
            识别媒体文件类型 (URL输入编辑框.内容, 临时媒体.取项目信息 (“Title”), 假)
            .如果 (临时媒体.取项目信息 (“Title”) = “V” 或 临时媒体.取项目信息 (“Title”) = “v” 或 临时媒体.取项目信息 (“Title”) = “s” 或 临时媒体.取项目信息 (“Title”) = “S”)
                写数据 (真, 网络flash文件名称框.内容, 到文本 (URL输入编辑框.内容), 读媒体时间 (URL输入编辑框.内容), 1, 取记录号 () + 1, 临时媒体.取项目信息 (“FileType”) + “ 类型”)
            .否则
                写数据 (真, 临时媒体.取项目信息 (“Title”), 到文本 (URL输入编辑框.内容), 读媒体时间 (URL输入编辑框.内容), 1, 取记录号 () + 1, 临时媒体.取项目信息 (“FileType”) + “ 类型”)
            .如果结束
            读数据 (真)
            打开URL.销毁 ()
        .否则
            .如果 (临时媒体.取项目信息 (“FileType”) ≠ “swf” 或 临时媒体.取项目信息 (“FileType”) ≠ “Swf”)
                写数据 (真, 临时媒体.取项目信息 (“Title”), 到文本 (URL输入编辑框.内容), 读媒体时间 (URL输入编辑框.内容), 1, 取记录号 () + 1, 临时媒体.取项目信息 (“FileType”) + “ 类型”)
            .否则
                信息框 (“无效URL地址”, 0, )
            .如果结束
            读数据 (真)
            打开URL.销毁 ()
        .如果结束

    .判断 (文件是否存在 (URL输入编辑框.内容) = 真)
        _启动窗口.播放器.地址 = URL输入编辑框.内容
        控制.播放 ()
        临时媒体 = _启动窗口.播放器.取当前媒体 ()
        _启动窗口.音乐列表框.全部删除 ()
        _启动窗口.目录识别框.清空 ()
        识别媒体文件类型 (URL输入编辑框.内容, 临时媒体.取项目信息 (“Title”), 假)
        写数据 (真, 临时媒体.取项目信息 (“Title”), 到文本 (URL输入编辑框.内容), 读媒体时间 (URL输入编辑框.内容), 1, 取记录号 () + 1, 临时媒体.取项目信息 (“FileType”) + “ 类型”)
        读数据 (真)
        销毁 ()
    .默认
        返回 ()
    .判断结束
    销毁 ()
.如果真结束


START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 20:06:57 |显示全部楼层
完美无误的上一曲或下一曲代码

.版本 2
.支持库 iext
.支持库 wmp9

.子程序 _上一个_被单击
.局部变量 地址变量识别, 整数型
.局部变量 上一个文件变量识别地址
.局部变量 地址类型判断变量, 文本型

当前被选中项 = 当前被选中项 - 1
.如果真 (当前被选中项 ≠ -1)
    地址类型判断变量 = 音乐列表框.取标题 (当前被选中项, 0)
    音乐列表框.现行选中项 = 当前被选中项
    .如果 (取文本左边 (地址类型判断变量, 4) = “http”)
        识别媒体文件类型 (音乐列表框.取标题 (当前被选中项, 1), 音乐列表框.取标题 (当前被选中项, 0), 假)
        播放器.地址 = 音乐列表框.取标题 (当前被选中项, 1)
        控制.播放 ()
    .否则
        识别媒体文件类型 (音乐列表框.取标题 (当前被选中项, 0), 音乐列表框.取标题 (当前被选中项, 1), 假)
        播放器.地址 = 音乐列表框.取标题 (当前被选中项, 1) + 音乐列表框.取标题 (当前被选中项, 0)
        控制.播放 ()
    .如果结束

.如果真结束

START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 20:07:58 |显示全部楼层
完美无错
.版本 2
.支持库 iext
.支持库 wmp9

.子程序 _下一个_被单击
.局部变量 地址变量识别, 整数型
.局部变量 上一个文件变量识别地址
.局部变量 地址类型判断变量, 文本型

当前被选中项 = 当前被选中项 + 1
.如果真 (当前被选中项 ≠ 取记录数 ())
    地址类型判断变量 = 音乐列表框.取标题 (当前被选中项, 0)
    音乐列表框.现行选中项 = 当前被选中项
    .如果 (取文本左边 (地址类型判断变量, 4) = “http”)
        识别媒体文件类型 (音乐列表框.取标题 (当前被选中项, 1), 音乐列表框.取标题 (当前被选中项, 0), 假)
        播放器.地址 = 音乐列表框.取标题 (当前被选中项, 1)
        控制.播放 ()
    .否则
        识别媒体文件类型 (音乐列表框.取标题 (当前被选中项, 0), 音乐列表框.取标题 (当前被选中项, 1), 假)
        播放器.地址 = 音乐列表框.取标题 (当前被选中项, 1) + 音乐列表框.取标题 (当前被选中项, 0)
        控制.播放 ()
    .如果结束

.如果真结束

START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 20:10:08 |显示全部楼层
数据库指向项目 删除掉
.版本 2
.支持库 iext

.子程序 _删除_被选择
.局部变量 索引, 整数型
.局部变量 循环变量

.计次循环首 (取记录数 (), 索引)
    循环变量 = 循环变量 + 1
    .如果真 (取记录数 () ≥ 循环变量)
        跳到 (循环变量)
        .如果真 (查找 (读 (#文件名称) = 音乐列表框.取标题 (vcslow, )))
            删除 ()
            彻底删除 ()
            音乐列表框.删除表项 (vcslow)
            目录识别框.删除项目 (vcslow)
            音乐列表框.全部删除 ()
            目录识别框.清空 ()
            读数据 (真)
            跳出循环 ()
        .如果真结束

    .如果真结束

.计次循环尾 ()
' 反逻辑_倒减算法 ()

START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

Rank: 7Rank: 7Rank: 7

帖子
567
精华
0
声望
2374 点
金币
344 Mold
被赞许
15 次
注册时间
2011-4-7

可爱小猫 懒人勋章

发表于 2012-5-19 20:11:11 |显示全部楼层
媒体文件 (所有类型)
[*.rm;*.ra;*.ram;*.rmvb;*.rp;*.rpm;*.rt;*.mov;*.qt;*.mkv;*.mka;*.mks;*.ac3;*.dts;*.lpcm;*.flv;*.swf;*.F4V;*.csf;*.ogg;*.ogm;*.ofr;*.ofs;*.mpc;*.mpp;*.mp+;*.tta;*.scm;*.smv;*.ts;*.tp;*.ape;*.flac;*.aac;*.wv|;*.GIF;*.BMP;*.JPG;*.PNG;*.TGA;*.TIFF;*.jpeg;*.rm;*.ra;*.ram;*.rmvb;*.rp;*.rpm;*.rt;*.mov;*.qt;*.mkv;*.mka;*.mks;*.wmv;*.wav;war;*.avi;*.arm;*.3GP;*.3G2;*.mp4;*.m4a;*.m4b;*.m4p;*.m4v;*.mp4v;*.3gp;*.3g2*.dvr-ms;*.flac;*.wv;*.acc;*.ape;*.asx;*.max;*.m3u;*.wpl;*.wvx;*.wvx;*.wmx;*.search-ms;*.scm;*.sdp;*.smv;*.wav;*.snd;*.au;*.aifc;*.aif;*.aiff;*.wma;*.mp2;*.mp3;*.adts;*.adt;*.aac;*.csf;*.mdi;*.rmi;*.m4a;*.MID;*.RMI;*.MIDI;*.mpeg;*.mpg;*.m1v;*.,2v;*.mod;*.mpa;*.mpe;*.ifo;*.vob;*.flv;*.swf;*.F4V;*.swf;*.f4v;*.flv]|Real/QuickTime/MKV 电影文件|*.rm;*.ra;*.ram;*.rmvb;*.rp;*.rpm;*.rt;*.mov;*.qt;*.mkv;*.mka;*.mks|DVD Audio Files|*.ac3;*.dts;*.lpcm|Flash Video Files|*.flv;*.swf;*.F4V|Collegesoft Files|*.csf|普通音频文件|*.ogg;*.ogm;*.ofr;*.ofs;*.mpc;*.mpp;*.mp+;*.tta
|SCM Media Files|*.scm;*.smv|高清视频文件|*.ts;*.tp;*.ape;*.flac;*.aac;*.wv|Windows 图片文件|*.GIF;*.BMP;*.JPG;*.PNG;*.TGA;*.TIFF;*.jpeg|RMVB 高清压缩文件|*.rm;*.ra;*.ram;*.rmvb;*.rp;*.rpm;*.rt;*.mov;*.qt;*.mkv;*.mka;*.mks|Wmp 视频音频文件|*.wmv;*.wav;war;*.avi;*.arm|MPEG-4/3GP File|*.3GP;*.3G2;*.mp4;*.m4a;*.m4b;*.m4p;*.m4v;*.mp4v;*.3gp;*.3g2|Microsoft 录制的电视节目|*.dvr-ms|无损压缩音乐|*.flac;*.wv;*.acc;*.ape|媒体播放列表|*.asx;*.max;*.m3u;*.wpl;*.wvx;*.wvx;*.wmx;*.search-ms|SCMedia|*.scm|SDP File|*.sdp|Super Media Video|*.smv|Windows 音频文件|*.wav;*.snd;*.au;*.aifc;*.aif;*.aiff;*.wma;*.mp2;*.mp3;*.adts;*.adt;*.aac|Collegesoft Files|*.csf|MPEG-4/3GP File|*.mdi;*.rmi;*.m4a|MDI 文件|*.MID;*.RMI;*.MIDI|电影文件|*.mpeg;*.mpg;*.m1v;*.,2v;*.mod;*.mpa;*.mpe;*.ifo;*.vob|所有文件 [*.*]|*.*
START /在我右心房的中心街部位,保留着那一份属于我们的仅存的记忆。有一种幸福叫等待,我要旳是爱不是安

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

回顶部